Applications Open Slow on SuSE Linux 10

While traveling here in Russia I ran into huge problem where my applications opened very slowly on my SuSE Linux 10 laptop. And I mean slow. I suspect this problem is applicable to Gnome, KDE, and any X environment, but I've only seen and solved in on SuSE 10 running Gnome 2.12. Applications that normally took a second or two at most to open, were taking around 20 seconds to open! I tried to use SuSE/Novell support to no avail (other than "Installation support" apparently there is not any despite the fact I bought SuSE 10), I searched all over SuSE/Novell, google, etc... Many people reported similar problems with SuSE and other Linux distros and many of them had some recommendation for resolving the problem posted, but often nobody confirmed that it worked.

Unfortunately, none of the recommendations I found solved my problem, but after trying many different things I was able to figure this out. It appears that the problem was solved using the following steps:

  1. Open YaST
  2. Select the Network Devices tab
  3. Choose Network Card
  4. Press the Edit button for your Network Card
  5. Press the Host Name and Name Server button
  6. Uncheck the Change Host Name via DHCP

I suspected this checkbox because I noticed that after I connected my network connection applications became very slow to launch, and in terminal windows the prompt changed from simply "[email protected]:~>" to "[email protected]:~> " (where xxx-xxx-xxx-xxx was the IP address assigned by DHCP). I hope this helps somebody else, and maybe helps SuSE fix this and make an even better product.